Back to overview
Downtime
Survival Server Down
Aug 28 at 08:10pm CEST
Affected services
Main
Resolved
Aug 28 at 08:23pm CEST
The issue has been resolved
Affected services
Main
Created
Aug 28 at 08:10pm CEST
Host notice: We are investigating the network issues in our Germany servers
Affected services
Main